更新日志

本文是WLNMP一键安装包永久更新地址!版本升级前请一定做好数据备份工作!以免某种原因导致升级失败!

使用过程中如果有什么意见或建议,欢迎加群反馈:$$

2024年5月28日

2024年5月22日

2024年5月11日

  • (更新)php8.2.19、php8.3.7

2024年5月9日

  • (更新)nginx1.26.0、openresty1.25.3.1
  • (其它)本次nginx,openresty更新后,如果原来使用listen 443 ssl http2;方式,现在需要更改成

listen 443 ssl;

http2 on;

    • 从nginx1.26.0开始,wlnmp一键安装包将原有的openssl 3.0.13替换为QuicTLS 3.0.13,增加nginx-rtmp-module、ngx_http_v3_module模块,正式支持HTTP/3协议,从该版本安装nginx后,默认不会启动nginx,手动启动可以通过/etc/init.d/nginx start或systemctl start nginx,所有OS默认依旧支持chkconfig自启动。
    • 从openresty1.25.3.1开始,默认openssl 1.1.1替换为QuicTLS 3.0.13,增加ngx_http_v3_module模块,正式支持HTTP/3协议,从该版本安装openresty后,默认不会启动openresty,手动启动可以通过/etc/init.d/nginx start或systemctl start nginx,所有OS默认依旧支持chkconfig自启动。
    • 注1:开启http3需要增加配置listen 443 quic reuseport;及add_header Alt-Svc 'h3=":443"; ma=86400';字段。
    • 注2:开启http3必须确保服务器防火墙、机房防火墙以及云端防火墙等,开放UDP 443端口。
    • 注3:http3检测网站:https://http3check.net/,出现如下图所示表示http3开启成功。

2024年5月6日

  • (新增)el9(9.x)增加RockyLinux9.x系统支持​。

2024年4月26日

  • (新增)el9(9.x)系统版本支持,新增AlmaLinux9.x系统兼容。
  • (其它)经过了长期大量的适配、测试工作,首个el9(9.x)系统AlmaLinux9.x完成适配兼容。
    • 软件版本与前期版本保持一致,对官方已停止维护更新的软件(如php5.6、php7.x等),在el9(9.x)系统中一样可用,但是出于安全考虑,还是建议大家使用稳定的版本。
    • 安装升级与前期版本保持一致,主要区别,在安装、升级软件后,服务不会自动重启,需要手动启动服务。
    • 启动停止与前期版本保持一致,同时支持/etc/init.d和systemctl两种管理方式,虽然官方不建议/etc/init.d这种方式,但兼顾用户体验,wlnmp依旧支持(因为/etc/init.d方便TAB命令补全)。
    • el9(9.x)软件包组做了多处优化,nginx、tengine默认依旧支持lua,但默认的waf脚本做了精简,仅提供了一个基础的防cc,用户可结合实际使用需求,自行添加其它的waf等。
    • 注意,在el9(9.x)版本中,在添加epel源的基础上,还需要开启crb源(dnf config-manager --set-enabled crb)。

2024年4月17日

  • (更新)php8.1.28、php8.2.18、php8.3.6

2024年3月21日

  • (更新)nginx、tengine、openresty增加大量扩展模块以及安全性升级,如mp4、flv、image_filter、realip等,查看具体扩展,安装后详见nginx -V。已安装的用户可以通过update直接升级,如yum update wnginx,注意:升级前做好重要数据备份,避免由于某些因素导致升级失败。

2024年3月20日

  • (bug修复)在OpenEuler22.03 SP3版本下安装php时,出现libicuio.so.69问题,详见https://github.com/wlnmp/wlnmp/issues/5

2024年3月18日

  • (更新)php8.2.17、php8.3.4、mariadb10.4.33、mariadb10.5.24、mariadb10.6.17、mariadb10.11.7、tssh0.1.19

2024年2月20日

  • (更新)php8.2.16、php8.3.3、redis7.0.15
  • (新增)redis7.2.4

2024年1月28日

  • (更新)tssh0.1.18

2024年1月26日

  • (更新)php8.2.15、php8.3.2、mysql8.0.36

2024年1月11日

  • (新增)mariadb10.4.32、mariadb10.5.23单版本和多版本支持,多个MySQL、Mariadb版本可以同时运行,注意同时运行需要安装wc开头的包组

2024年1月6日

  • (新增)wcmariadb106、wcmariadb1011,mariadb也可以和MySQL多版本并存了,多个MySQL、Mariadb版本可以同时运行,注意同时运行需要安装wc开头的包组

2024年1月4日

  • (更新)php8.1.27、php8.2.14、php8.3.1

2023年12月31日

  • (更新)tssh0.1.17

2023年12月30日

  • (更新)mariadb10.11.6、mariadb10.6.16
  • (其它)2023年度的最后一次全版本更新,彻底解决/etc/init.d启动方式与systemctl并存问题。通过/etc/init.d/SOFT启动的程序,也可通过systemctl stop SOFT停止,反之同理,两种方式任选其一。例如:/etc/init.d/mysql8 start启动等同于systemctl start mysql8。

2023年12月23日

  • (更新)tssh0.1.16、trzsz1.1.7

2023年12月15日

  • (更新)nginx1.24.0-2、openresty1.21.4.3、tengine3.1.0,从该版本开始支持systemctl start/stop/restart/status SOFT启动停止,与原有/etc/init.d/SOFT start/stop/restart互联兼容。
  • 例如:重启服务systemctl restart nginx,因为nginx、openresty、tengine都是基于nginx的,所以启动停止SOFT名称都是nginx

2023年12月13日

  • (其它)关于wlnmp一键安装包rsync镜像源同步说明,不再单独提供某个系统的镜像源,仅保留一个总的rsync同步源,如需单独同步某个系统源,自行增加rsync判断,参见镜像源:https://www.wlnmp.com/mirrors
  • (其它)需求建议收集可在GitHub上提交Issues:https://github.com/wlnmp/wlnmp/issues

2023年12月10日

  • (更新)tssh0.1.15

2023年12月1日

  • (新增)Alibaba CloudLinux 2.1903
  • (其它)恢复对CentOS 8.x系统的支持
  • (新增)支持一键自动安装WLNMP源了,只要在wlnmp一键安装包支持的系统版本上直接执行(curl -fsSL "https://sh.wlnmp.com/wlnmp.sh" | bash)即可完成源的安装。

2023年11月30日

  • (新增)Alibaba CloudLinux3支持

2023年11月29日

  • (更新)php8.1.26、php8.2.13
  • (新增)php8.3.0

2023年11月26日

  • (更新)tssh0.1.14

2023年11月12日

  • (更新)tssh0.1.13

2023年11月5日

  • (更新)php8.1.25、php8.2.12、redis6.2.14、redis7.0.14、mysql5.7.44、mysql8.0.35
  • (其它)MySQL8默认的binlog_format=mixed更改为binlog_format=ROW
    MySQL8新增general_log = off、general_log_file = /data/mysql/general.log参数
    注意:如果你从未更改过MySQL配置文件(如my.cnf、my8.cnf),那么升级后,会将默认的MySQL配置文件替换为新的,如果你曾经更改过MySQL配置文件,那么升级MySQL版本后不会更改你的my.cnf文件。如果修改了配置文件中datadir、pid时,需同步修改/etc/init.d/下的启动脚本中的对应路径。

2023年10月22日

  • (更新)tssh0.1.12、trzsz1.1.6

2023年10月7日

  • (更新)php8.1.24、php8.2.11

2023年9月13日

  • (更新)php8.1.23、php8.2.10、redis7.0.13

2023年9月3日

  • (更新)php8.2.9、mariadb10.11.5、mariadb10.6.15

2023年8月27日

  • (更新)tssh0.1.11

2023年8月14日

  • (更新)tssh0.1.10

2023年8月9日

  • (更新)php8.1.22、php8.0.30

2023年7月31日

  • (更新)tssh0.1.9、trzsz1.1.5

2023年7月26日

  • (更新)redis6.0.20、redis6.2.13、redis7.0.12、mysql5.7.43、mysql8.0.34

2023年7月23日

  • (更新)tssh0.1.8

2023年7月16日

  • (新增)(更新)tssh0.1.7、trzsz1.1.4

2023年7月8日

  • (更新)php8.1.21、php8.2.8

2023年6月29日

  • (新增)7.x系统php8.2版本新增sg11、smbclient、redis、memcached、imagick。7.x系统php扩展查询见:https://www.wlnmp.com/php_extension/php_extension_7

  • (更新)8.x系统多版本php扩展模块与单版本保持一致,扩展模块支持查询见:https://www.wlnmp.com/php_extension/php_extension_8

  • (新增)8.x系统php新增memcache、redis扩展模块

  • (其它)本次7大系统共计新增328个php扩展模块,至此php单版本和多版本的扩展模块全部保持一致。

2023年6月27日

2023年6月25日

  • (bug修复)修复8.x系列操作系统安装wkeepalived时找不到libnl.so.1模块的bug

2023年6月22日

  • (更新)keepalived2.2.8、mariadb10.6.14、mariadb10.11.4、php8.0.29、php8.1.20、php8.2.7

  • (更新)新增以下版本对多版本并存时的判断,当同版本安装时会有报错提示:mysql5.5.62-2、mysql5.6.51-2、mysql5.7.42-2、mysql8.0.33-2、php5.6.40-2、php7.0.33-2、php7.1.33-2、php7.2.34-2、php7.3.33-2、php7.4.33-2

  • (新增)MySQL8版本my.cnf文件新增mysqlx参数
  • (新增)php、MySQL多版本并行安装运行,安装使用见:https://www.wlnmp.com/install

  • (其它)本次大版本更新7个系统,新增共计203个包,php和MySQL的多版本并行,已经进行了大量的回归测试,解决了大量并行时存在的bug

2023年6月4日

  • (新增)MariaDB10.11.3

2023年5月21日

  • (更新)php8.1.19、php8.2.6、redis6.0.19、redis6.2.12、redis7.0.11、mysql5.7.42、mariadb10.6.13

2023年4月23日

  • (更新)nginx1.24.0、php8.1.18、php8.2.5

  • (更新)nginx中所使用的组件升级ngx_devel_kit0.3.2、lua-nginx-module0.10.24、openssl3.0.8、lua-resty-lrucache0.13、gperftools2.10
  • (更新)luaJIT2升级至2.1.20230119
  • (bug修复)nginx1.24.0修复nginx.conf软waf找不到core.lua问题

2023年3月17日

  • (更新)php8.1.17、php8.2.4、redis7.0.9

2023年3月1日

  • (bug修复)修复php8.2.3默认php.ini模块路径错误的问题,修复后版本为php8.2.3-2
  • (新增)php74-dba、php74-fileinfo、php74-imap、php74-ldap、php74-sysvmsg、php8-dba、php8-fileinfo、php8-imap、php8-ldap、php8-sysvmsg、php81-dba、php81-fileinfo、php81-imap、php81-ldap、php81-sysvmsg、php82-dba、php82-fileinfo、php82-imap、php82-ldap、php82-sysvmsg

2023年2月22日

  • (更新)php8.0.28、php8.1.15、php8.1.16、php8.2.2、php8.2.3
  • (新增)php71-ldap、php71-snmp
  • (删除)由于UOS统信源商业版原因,停更并删除其源,如有使用需求,请使用UOS上游版本进行安装

2023年2月6日

  • (更新)php8.0.27、php8.1.14、php8.2.1、MySQL5.7.41、MySQL8.0.32
  • (新增)redis6.0.17

2022年12月11日

  • (更新)php8.2.0更新至正式稳定版,wlnmp源不在保留php8.2历史的RC版本

2022年12月2日

  • (更新)php8.0.26、php8.1.13、php8.2.0RC7

2022年11月24日

  • (更新)php7.4.33、php8.2.0RC6
  • (新增)MariaDB10.6.11

2022年11月10日

  • (更新)redis7.0.5、php8.0.25、php8.1.12、php8.2.0RC5、MySQL5.7.40、MySQL8.0.31

2022年9月30日

  • (更新)php7.4.32、php8.0.24、php8.1.11

2022年9月24日

  • (更新)php8.0.23、php8.1.10、php8.2.0RC2

2022年8月19日

  • (bug修复)修复AnolisOS8系统wmysql57安装后提示error while loading shared libraries: libatomic.so.1报错

2022年8月14日

  • (新增)OpenEuler22.03LTS系统支持
  • (更新)redis7.0.4、php8.0.22、php8.1.9、php8.2.0beta2、MySQL5.7.39、MySQL8.0.30

2022年7月14日

  • (新增)OpenCloudOS8.x系统支持
  • (更新)redis7.0.3、php8.0.21、php8.1.8、php8.2.0alpha3

2022年6月21日

2022年6月19日

  • (更新)openresty-1.21.4.1.spec
  • (新增)keepalived2.2.7、redis6.2.7、redis7.0.2,安装方式:yum install wkeepalived、yum install wredis62、yum install wredis7
  • (更新)RockyLinux8、openeuler20.3、AlmaLinux8、AnolisOS8为方便后期源升级,安装源方式更新,请见安装使用文档:https://www.wlnmp.com/install

2022年6月11日

  • (更新)php7.4.30、php8.0.20、php8.1.7、nginx1.22.0
  • (新增)php8.2.0alpha1
  • (其它)nginx1.22.0新增php8.2扩展支持(include enable-php82.conf;),nginx1.22.0采用openssl3.0.3封装

2022年5月30日

  • (bug修复)修复MySQL5.7版本使用mysqldump无法导出的问题,请使用yum update wmysql57进行升级,升级前请做好备份

2022年5月15日

  • 本次更新除版本升级外,主要解决原有部分系统对部分软件版本不支持情况,保障系统之间软件版本一致性。
  • (新增)RockyLinux8、AlmaLinux8、UOSV20(1050a)、OpenEuler20.3、AnolisOS8增加ntpdate包支持,安装方式yum install wntp
  • (新增)RockyLinux8、UOSV20(1050a)增加spine包支持
  • (新增)RockyLinux8、AlmaLinux、UOSV20(1050a)、AnolisOS8增加rrdtool包支持
  • (新增)OpenEuler20.3增加php7.0.33包支持
  • (更新)CentOS7/RedHat7、RockyLinux8、AlmaLinux8、UOSV20(1050a)、OpenEuler20.3、AnolisOS8系统更新mysql8.0.29、mysql5.7.38、php8.0.19、php7.4.29、php8.1.6、spine1.2.20、rrdtool1.8.0

2022年4月10日

  • 新增UOS统信服务器操作系统V20(1050a)支持,版本详情查看:https://www.wlnmp.com/release
  • 注:仅支持统信服务器操作系统V20(1050a)版本,1050e、1050d等其它版本存在特殊性,暂不兼容!

2022年3月27日

  • CentOS7/RedHat7默认php扩展支持见:https://www.wlnmp.com/post-630.html
  • CentOS7/RedHat7额外php扩展支持见:https://www.wlnmp.com/post-628.html
  • centos7系统php8.0、php8.1新增扩展模块:amqp-1.11.0、apcu-5.1.21、dba、fileinfo、gnupg-1.5.1、igbinary-3.2.7、imagick-3.7.0、imap、ldap、memcache-8.0、memcached-3.1.5、redis-5.3.7、sg11-13.0.2、smbclient-1.0.6、sysvmsg、xlswriter-1.5.1、yaf-3.3.4、zend_test
  • centos7系统php7.4新增扩展模块:amqp-1.11.0、gnupg-1.5.1、igbinary-3.2.7、memcache-8.0、xlswriter-1.5.1、yaf-3.3.4
  • centos7系统php7.4升级扩展模块:apcu-5.1.21、imagick-3.7.0、redis-5.3.7、smbclient-1.0.6
  • centos7系统php7.3新增扩展模块:amqp-1.11.0、gnupg-1.5.1、igbinary-3.2.7、memcache-8.0
    centos7系统php7.3升级扩展模块:apcu-5.1.21、imagick-3.7.0、memcached-3.1.5、redis-5.3.7、smbclient-1.0.6、tidy、xlswriter-1.5.1、yaf-3.3.4
  • centos7系统php7.2新增扩展模块:amqp-1.11.0、dba、gnupg-1.5.1、igbinary-3.2.7、memcache-8.0、memcached-3.1.5、readline、tidy、zend_test
  • centos7系统php7.2升级扩展模块:apcu-5.1.21、imagick-3.7.0、redis-5.3.7、smbclient-1.0.6、xlswriter-1.5.1、yaf-3.3.4
  • centos7系统php7.1新增扩展模块:dba、gnupg-1.5.1、memcache-4.0.5.2、readline
  • centos7系统php7.1升级扩展模块:amqp-1.11.0、apcu-5.1.21、igbinary-3.2.7、imagick-3.7.0、memcached-3.1.5、redis-5.3.7、smbclient-1.0.6、xlswriter-1.5.1、yaf-3.3.4
  • centos7系统php7.0新增扩展模块:amqp-1.11.0、dba、gnupg-1.5.1、igbinary-3.2.7、memcache-4.0.5.2、memcached-3.1.5、readline、tidy
  • centos7系统php7.0升级扩展模块:apcu-5.1.21、imagick-3.7.0、redis-5.3.7、xlswriter-1.5.1、yaf-3.3.4
  • centos7系统php5.6新增扩展模块:amqp-1.11.0、dba、enchant、exif、gnupg-1.5.1、readline、sysvmsg、tidy
    centos7系统php5.6升级扩展模块:imagick-3.7.0

2022年3月17日

  • (bug修复)CentOS7新增wlibzip安装包,解决在使用php7.4、php8.0、php8.1时报错php: error while loading shared libraries: libzip.so.5: cannot open shared object file: No such file or directory

2022年3月15日

  • CentOS7/OpenEuler20.3/RockyLinux8/AlmaLinux8/AnolisOS8系统php版本升级至7.4.28、8.0.16、php8.1.3

2022年1月29日

  • CentOS7/OpenEuler20.3/RockyLinux8/AlmaLinux8/AnolisOS8系统php版本升级至8.0.15、php8.1.2
  • CentOS7/OpenEuler20.3/AnolisOS8系统mysql版本升级至8.0.28
  • CentOS7系统openresty版本升级至1.19.9.1

2022年1月9日

  • 停止对Centos8的软件版本支持,后续不再更新
  • CentOS7/OpenEuler20.3/RockyLinux8/AlmaLinux8/AnolisOS8系统php版本升级至8.1.1、8.0.14、7.4.27

2022年1月2日

  • 新增AnolisOS8版本支持
    • rpm -ivh https://mirrors.wlnmp.com/anolisos/wlnmp-release-anolisos-1-1.noarch.rpm

2021年12月18日

  • 新增OpenEuler20.3/AlmaLinux8版本支持
    • rpm -ivh https://mirrors.wlnmp.com/openeuler/wlnmp-release-openeuler-1-1.noarch.rpm
    • rpm -ivh https://mirrors.wlnmp.com/almalinux/wlnmp-release-almalinux-1-1.noarch.rpm
  • 详细的软件版本支持见版本支持

2021年12月11日

  • 新增RockyLinux8版本支持
    • rpm -ivh https://mirrors.wlnmp.com/rockylinux/wlnmp-release-rocky-1-1.noarch.rpm
  • RockyLinux8支持的安装包php7.0、php7.1、php7.2、php7.4、php8、php8.1、nginx、openresty、tengine、mysql5.5、mysql5.6、mysql5.7、mysql8

2021年11月29日

  • nginx升级至1.20.2稳定版,其中nginx所使用的openssl更新至1.1.1l,更新后新增php8.1版本支持,可使用include enable-php8.conf;引用,支持php8.1
  • 新增php8.1版本,yum install wphp81
  • 升级前请备份数据,避免升级后发生问题,导致服务不可用

2021年11月28日

  • php版本升级8.0.13、7.4.26、7.3.33

2021年11月16日

  • php版本升级7.3.32
  • mysql版本升级8.0.27、5.7.35

2021年10月27日

  • php版本升级7.4.25、8.0.12

2021年10月09日

  • php版本升级7.4.24,MySQL版本升级8.0.26

2021年09月30日

  • php版本升级7.3.30、7.3.31、7.4.22、7.4.23、8.0.9、8.0.10、8.0.11

2021年08月08日

  • php版本升级7.3.29、7.4.21、8.0.8

2021年06月25日

  • tengine更新至2.3.3
  • nginx更新至1.20.1
  • luaJIT2更新至2.1.20210510

2021年06月6日

  • MySQL版本升级8.0.25、5.7.34

2021年05月26日

  • php版本升级7.4.19、8.0.6

2021年04月24日

  • nginx更新至1.20.0稳定版

2021年04月5日

  • 新增transmission-2.94包,安装方法:yum install wtransmission

2021年03月21日

  • php版本升级7.4.16、8.0.3

2021年02月06日

  • 新增php7.1、7.2、7.3、7.4版本CAS1.3.8版本依赖的支持,安装例:yum install wphp74-cas
  • MySQL版本升级5.6.51
  • php版本升级7.3.27、7.4.15、8.0.2

2021年01月21日

  • 本次仅针对于CentOS7/8、Redhat7/8版本,自2021年开始不再对CentoOS6/Redhat6版本进行升级维护!
  • php版本升级7.3.26、7.4.14、8.0.1
  • mysql版本升级5.6.50、5.7.32、8.0.23

2020年10月15日

  • php8.0.0rc2版本更新,修复opcache模块未启用及模块路径错误的问题

2020年10月15日

  • php版本升级7.2.34、7.3.23、7.4.11
  • CentOS7/Redhat7,CentOS8/Redhat8,新增php8.0rc1版本,该版本仅供测试

2020年09月15日

  • Centos6、Centos7系统,对spine版本升级,spine升级版本1.2.8至1.2.14,截至目前建议还是使用1.2.7,spine版本与Cacti版本无需对应

2020年09月10日

  • php版本升级7.2.33、7.3.22、7.4.10
  • 新增openresty支持,安装方式yum install wopenresty,启动停止目录结构和Nginx保持一致,源码包基于openresty封装

2020年08月06日

  • php版本升级7.2.32、7.3.20、7.4.8

2020年07月03日

  • 修复php7.4安装时,提示缺少libonig.so.2()(64bit)的bug

2020年06月12日

  • php版本升级7.3.19、7.4.7

2020年05月31日

  • php版本升级7.2.31、7.3.18、7.4.6c
  • 修复CentOS6系统下安装php-memcached缺少libmemcached的错误
  • 取消CentOS6系统下php7.3的memcached扩展支持

2020年05月08日

  • CentOS7系统mysql版本升级8.0.20、5.6.48、5.7.30
  • CentOS8系统mysql版本升级8.0.20、5.6.48、5.7.30

2020年04月29日

  • 修复CentOS7下php扩展模块imagick、apcu、mbclient安装及重启php出错的bug

2020年04月26日

  • mysql版本升级5.6.47、5.7.29

2020年04月25日

  • CentOS7系统php5.6增加imap、imagick、smbclient、fileinfo扩展模块支持
  • CentOS7系统php7.0增加imap、imagick、smbclient、fileinfo、apcu扩展模块支持
  • CentOS7系统php7.1增加imap、smbclient、fileinfo、apcu扩展模块支持
  • CentOS7系统php7.2增加imap、imagick、smbclient、fileinfo、apcu扩展模块支持
  • CentOS7系统php7.3增加imap、imagick、smbclient、fileinfo、apcu扩展模块支持
  • CentOS7系统php7.4增加imap、imagick、smbclient、fileinfo、apcu、ldap扩展模块支持

2020年04月22日

  • php版本升级7.2.30、7.3.17、7.4.5
  • nginx版本升级1.18.0

2020年03月20日

  • php版本升级7.2.29、7.3.16、7.4.4

2020年02月21日

  • php版本升级7.2.28、7.3.15、7.4.3

2020年01月27日

  • php版本升级7.2.27、7.3.14、7.4.2

2020年01月17日

  • 全版本新增Tengine支持,安装方法:yum install wtengine

2020年01月15日

  • RedHat8/CentOS8更新MySQL包,安装MySQL后需手动启动

2019年12月19日

  • php版本升级7.2.26、7.3.13、7.4.1

2019年12月10日

  • 修改wlnmp-release-centos.repo中gpgkey认证方式

2019年11月28日

  • 增加php7.4.0支持

2019年11月26日

  • php版本升级7.2.25、7.3.12

2019年11月18日

  • nginx1.16.1版本更新,增加php7.4支持,已在使用nginx1.16.1的用户可以卸载重装以便可以支持php7.4,或等nginx下一个稳定版升级
  • 增加php7.4.0rc6版本测试

2019年11月13日

  • 修复CentOS7下php71-snmp模块的错误

2019年11月04日

  • CentOS6/RedHat6系统支持mysql8.0了
  • mysql版本升级mysql5.6.46、mysql5.7.28

2019年10月27日

  • CentOS7/RedHat7系统php7.0、php7.2、php7.3增加redis扩展
  • CentOS6/RedHat6系统php7.0、php7.2增加redis扩展
  • CentOS6/RedHat6系统php5.6升级redis扩展至4.3.0

2019年10月26日

  • php版本升级7.1.33、7.2.24、7.3.11
  • php模块扩展重大更新,更新后所有php模块支持update一键升级了
  • Centos7、Redhat7系统php7.0、php7.1、php7.2、php7.3增加calendar、enchant、exif、pspell、recode、sysvmsg、wddx扩展。安装例:yum install wphp70-calendar

2019年10月24日

  • Centos7、Redhat7系统php5.6、php7.0、php7.1、php7.2、php7.3增加sg11扩展。例:yum install wphp56-sg11
  • Centos7、Redhat7系统php7.0、php7.1、php7.2、php7.3增加yaf扩展。例:yum install wphp70-yaf
  • Centos6、Redhat6系统php7.0、php7.1、php7.2增加yaf扩展。例:yum install wphp70-yaf

2019年10月21日

  • spine版本升级至1.2.7

2019年10月16日

  • MySQL8版本升级至8.0.18

2019年09月29日

  • php7.2版本升级至7.2.23
  • php7.3版本升级至7.3.10

2019年09月26日

  • CentOS8.0增肌ntp安装包,yum install wntp

2019年09月22日

  • wss升级,默认使用chacha20-ietf加密方式

2019年09月21日

  • 增加MySQL8

2019年09月10日

  • Centos7/Redhat7
    • php7.0新增xlswriter模块支持
    • php7.1新增xlswriter、sodium模块支持
    • php7.2新增xlswriter模块支持
    • php7.3新增xlswriter模块支持
  • Centos6/Redhat6
    • php5.6新增snmp、gmp、memcache模块支持
    • php7.0新增xlswriter模块支持
    • php7.1新增xlswriter模块支持
    • php7.2新增xlswriter模块支持

2019年09月09日

  • nginx重大更新,该版本基于openssl-1.1.1c封装,支持TLS1.3,修复wnginx版本升级后,开机自启失效的问题。
    • 升级前请先卸载原来的包组,方式如下,强烈建议升级到此版本

2019年09月03日

  • spine升级至1.2.6

2019年09月01日

  • php7.1版本升级至7.1.32
  • php7.2版本升级至7.2.22
  • php7.3版本升级至7.3.9

2019年08月25日

  • mysql版本升级mysql5.7.27、mysql5.6.45
  • wmysql重大更新,此次更新针对于Centos7及Centos6下所有wmysql。
    • 1、解决在Centos7系统下,安装wmysql时与mariadb-libs包组冲突的问题,现已完全兼容,安装wmysql时,再也不需要先卸载mariadb-libs包了。
    • 2、解决在Centos6系统下,安装wmysql时于mysql-libs包组冲突的问题,现已完全兼容,安装wmysql时,再也不需要先卸载mysql-libs包了。
    • 3、修复wmysql在版本升级后,mysql不启动的问题。
    • 4、修复wmysql在版本升级后,开机自启mysql失败的问题。
    • 5、优化wmysql在安装完成后环境变量的问题,在安装完成后,重新登录终端即可,也可手动使用source /etc/profile命令刷新,立即生效
    • PS:建议所有使用老版本wmysql的用户,升级到此次新的版本,升级卸载请一定备份好数据,以免由于某些因素导致数据丢失。

2019年08月14日

  • nginx版本升级至1.16.1

2019年08月01日

  • php版本升级php7.1.31、php7.2.21和php7.3.7

2019年07月31日

  • Centos6环境下php7.1增加了7个扩展模块,(amqp、igbinary、imagick、phalcon、redis、tidy、memcached),安装方式例:yum install wphp71-tidy

2019年07月26日

  • Centos7环境下php7.1增加了7个扩展模块,(amqp、igbinary、imagick、phalcon、redis、tidy、memcached),安装方式例:yum install wphp71-tidy

2019年07月24日

  • php7.1增加了几个参数‘--with-kerberos’ ‘--with-libdir=lib64’ ‘--with-pcre-regex’ ‘--with-pear’ ‘--enable-sysvshm’ ‘--with-pdo-sqlite’ ‘--enable-libxml’

2019年07月16日

  • wspine版本升级1.2.5

2019年07月04日

  • php版本升级php7.2.20和php7.3.7

2019年06月26日

  • nginx增加ngx_stream_core_module模块支持

2019年06月12日

  • wspine版本升级1.2.4

2019年06月05日

  • php版本升级php7.1.30、php7.2.19和php7.3.6

2019年05月05日

  • php版本升级php7.1.29、php7.2.18和php7.3.5

2019年04月24日

  • nginx升级1.16.0,升级前请做好备份

2019年04月17日

  • php7.2增加sodium模块扩展
  • php7.3增加sodium模块扩展
  • memcached版本升级1.5.13

2019年04月11日

  • Nginx_lua_waf修改,使用https://github.com/whsir/ngx_lua_waf替换原版ngx_lua_waf

2019年04月07日

  • php版本升级php7.1.28、php7.2.17和php7.3.4

2019年04月03日

  • Nginx日志通过logrotate每日自动进行压缩
  • 设置Nginx日志默认路径为/data/logs/nginx
  • nginx_waf一个bug修改

2019年03月19日

  • Nginx集成TCMalloc

2019年03月14日

  • 修复Centos7系统下,安装php7.2-snmp模块错误的问题

2019年03月12日

  • php7.0、php7.1、php7.2、php7.3增加snmp模块

2019年03月08日

  • 增加MySQL5.6版本支持

2019年03月07日

  • 增加memcached服务端
  • php7.3增加memcached扩展
  • php7.X增加ldap扩展

2019年03月06日

  • 全面支持php7.0、php7.1、php7.2、php7.3版本

2019年01月01日

  • 首个wlnmp测试版发布